Reached unfoldedLine buffer limit


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

  • Error message: Buffer limit exceeded. Reached unfoldedLine buffer limit: 102400 bytes
  • Message is rejected at receiver

Causes:

  • The message header has a single continued line that exceeds the limit of 100K bytes
  • MailMarshal treats such messages as malformed and rejects them.

Resolution:

A header line of 100K bytes (spanning multiple continuation lines) should be adequate for valid email messages. Messages with longer header lines may well be malformed. They could even be deliberately malformed in an attempt to create a buffer overflow.

MailMarshal takes the safe approach and rejects any messages which exceed this limit. Increasing the limit could leave you vulnerable to a header exploit. If this issue occurs rarely, then the safest option would be to do nothing.  If you are constantly getting this message or the source of the rejected email is known to be good, please contact Trustwave Technical Support to discuss debugging and further configuration.


Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle14215.aspx