Faulting module SpamChecker.dll


This article applies to:

  • Trustwave MailMarshal (SEG)
  • Trustwave ECM/MailMarshal Exchange 7.X

Symptoms:

  • Error: faulting module SpamChecker.dll
  • MailMarshal Engine stops or will not start

Causes:

  • This error indicates a problem with one or more of the "category script" XML files.
  • For a specific, older upgrade issue that could cause this message, see Q11704.

Resolution:

This issue will typically occur immediately after you make a change in a category script XML file. To correct the issue, revert the change.

If you made several changes or you are unsure what changes have been made:

  1. Remove any custom XML file inclusions from default XML files such as the SpamCensor or Zero Day files.
  2. Remove any custom rule conditions that use the rule condition "Where messages is categorized as..."
  3. Commit configuration and ensure that the engine can process messages.
  4. Add the conditions or file inclusions to the configuration one by one, commit configuration, restart the engine and check that the engine will process messages. If the engine stops, the last XML file you added is likely to be the cause.

 



Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle14025.aspx