Error accessing SQM after installing on a Windows Server 2008 (x64) system platform joined to a domain


This article applies to:

  • Trustwave MailMarshal (SEG) Spam Quarantine Management website

Symptoms:

  • When attempting to access the end-user management website (SQM), you see an error similar to the following:  


    Error Message

    Server Error in Application "application name"
    HTTP Error 500.19 – Internal Server Error
    HRESULT: 0x8007000d
    Description of HRESULT
    The requested page cannot be accessed because the related configuration data for the page is invalid.

    Detailed Error Information
    Module StaticCompressionModule Notification MapRequestHandler Handler StaticFile Error Code 0x8007007e

    Requested URL http://localhost:80/SpamConsole
    Physical Path C:\Program Files (x86)\Marshal\MailMarshal Web Components\Spam Quarantine Management
    Logon Method: Negotiate
    Logon User: {Your  Username}

    Most likely causes:
    *The worker process is unable to read the applicationhost.config or web.config file.
    *There is malformed XML in the applicationhost.config or web.config file.
    *The server cannot access the applicationhost.config or web.config file because of incorrect NTFS permissions
    .


     
  • You may also see the generic Server Error message indicating that an error has occurred but error reporting is not configured

Causes:

  • The account used as the identity by the Classic .NET Application Pool has insufficient privileges to complete your request. By default the Classic .NET App Pool uses an identity of "ApplicationPoolIdentity". 

Resolution:

In order to correct this error, do the following

IIS 7.0

  1. Open IIS Manager (Start | Settings | Control Panel | Administrative Tools | Internet Information Services (IIS) Manager).
  2. Expand "Application Pools."
  3. Add an Application Pool named “SpamConsole”
  4. Right-click on the newly created "SpamConsole" and select “Advanced Settings."
  5. Find the "Identity" tab on the "SpamConsole” Application Pool Properties window.
  6. Change ApplicationPoolIdentity to "Network Service" from the drop down list
  7. Save the change.
  8. Restart IIS from the command line using “IISreset”

Notes:

  • Current versions of the installer create and use an appropriate Application Pool.
  • For more information about issues with this environment, please review the following Trustwave Knowledgebase Article:
    • Q12671Additional Configuration to run Web Components on Windows 2008 64 bit editions (including SBS2008) 

Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle13952.aspx