This article applies to:
- Marshal Reporting Console
- MailMarshal SPE 3.0 and above
Symptoms:
Causes:
- The services executables are authenticode signed. The signing certificate is validated on startup.
- This process requires access to a Certificate Revocation List (generally via HTTP), but the servers affected do not have access to this URL.
- This is a known issue affecting .NET services, when strict security is enforced in a domain.
- Other critical Windows services have not yet started
Resolution:
For the CRL problem, several options are available to resolve this issue. Options are listed below in order from most to least secure.
-
Allow access from the server(s) to the CRL (crl.verisign.com or crl.trustwave.com depending on product version)
-
Create a configuration file to disable CRL checking for the affected Agents. For information, see Microsoft Knowledge Base article
.NET configuration information for the
generatePublisherEvidence element.
- Locate the .config file for each service
- Within the Configuration section, BELOW the end of the "configSections" section, add the following lines:
<runtime>
<generatepublisherevidence enabled="false">
</generatepublisherevidence>
</runtime>
-
Increase the service startup timeout and/or decrease the timeout on the CRL checking.
For other cases where CRL access has been confirmed
- Change the service startup type to "Automatic (Delayed Start)"