This article applies to:
Symptoms:
- Customer attempting to import more than 20,000 SQM user logins to SPE Customer Console
- The import times out and no items are actually imported.
- Customer or provider running reports for many users or other large datasets (Customer Console or Admin Console)
- Report generation times out
Causes:
- The request has been terminated by the HTTP run time limitation in ASP.NET
Resolution:
For large reports that are run often, consider running the report as a scheduled report.
To resolve the timeout issue, you can edit the web.config file for the Customer Console and/or the Admin Console.
- For the Customer Console, see the CustomerConsole subfolder of the installation (on the web server where Customer Console is installed).
- For the Admin Console, see the Website subfolder of the installation (on the web server where Admin Console is installed).
- Within system.web, locate or add the element httpRuntime
- Add or edit the attribute executionTimeout. The value is in seconds.
- The default value is 110 seconds for the Admin Console, and for Customer Console version 3.1 and below
- The default for the Customer Console 3.2 and above is 600 seconds
- To set the timeout to 1000 seconds, you can enter the following:
<httpRuntime executionTimeout="1000" />
- You may need to set a value above 1000 seconds, particularly for the Admin Console with very large reports.
Notes:
- If the element httpRuntime already exists with other attributes, do not remove the other attributes. Simply add the new attribute.
- The config file is case sensitive.
- On upgrade to version 3.2, the value for the Customer Console is changed to the new default 600 seconds.
- See also Q11777, SQL Command Timeout for all the reports is too low for large sites