Dashboard shows no data


This article applies to:

  • WebMarshal 6.X or 7.X
  • Windows operating system international versions

Symptoms:

  • No data displays in WebMarshal dashboard
  • Errors in the WebMarshal Controller log: Failed to open performance data, retrying in 5 seconds

Causes:

  • WebMarshal retrieves system Performance Counter data by text name. This is the standard technique.
  • WebMarshal uses the following system Performance Counters:
    • \Processor(_Total)\% Processor Time
    • \Memory\% Committed Bytes In Use
    • \[install disk drive name]\% Free Space
  • When Windows is installed using an operating system version other than English, the counter names differ.

Resolution:

  • Verify that the WebMarshal performance monitor dll is successfully registered.
  • To ensure that WebMarshal can retrieve Performance Counter data, install WebMarshal only on an English language version of Windows.
  • Changing Windows regional settings or input language (Language Bar) does not resolve or cause this issue.
  • Use of the Windows Multilingual User Interface (MUI) optional add-in to set the interface language could affect this issue. Microsoft states that Windows 2003 Performance Counters are MUI aware.

Notes:

Trustwave is researching improvements to the counter retrieval functionality.


Last Modified 7/6/2010.
https://support.trustwave.com/kb/KnowledgebaseArticle13889.aspx