Repeated system restart when installing SQL Express


This article applies to:

  • SQL 2008 Express (or later version) installation

Symptoms:

  • When installing SQL 2008 Express for use with MailMarshal or WebMarshal you may constantly be asked to restart the system.
  • Restarting does not clear this problem.

Causes:

  • This issue can be caused when Windows does not correctly update the list of files to be renamed at restart.

Resolution:

To resolve this issue:

  1. Edit the Windows Registry.
  2. Navigate to the following location:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
  3. Remove the value named PendingFileRenameOperations
    (For more information about this value and its use, see Microsoft websites.)
  4. Do not restart the computer.
  5. Rerun SQL Express installation.

Notes:

  • As always, back up the Registry and take due care when editing.
  • This issue is more likely to occur if multiple SQL installations have been performed on the server.

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle13809.aspx