ER Admin GUI cannot load if workstation language settings are not supported


This article applies to:

  • ER 5.1 Only

Symptoms:

  • After changing the language on the box (Settings -> Control Panel -> Regional and Language Options) from US English to another language, the user is unable to log into the Admin GUI; it appears to hang

Causes:

  • The Admin GUI cannot handle language settings when only one language is specified in the browser window, and that language is not supported by the ER Admin GUI. It expects other languages and as such, checks indefinitely.

    If there is only one language (e.g. es-mx) selected in the browser setting, and that particular language does not belong to the supported list (i.e. en_us, zh_cn or zh_tw), then the ER will go into an infinite loop, and thus the Admin GUI hangs.

Resolution:

Select English (en-us) in the browser language setting, and shift the preferred language to the top.      

For IE:

a.      Tools à Internet Options

b.      Go to “General” tab.

c.       Click “Languages”.

d.      Select “English (United States) [en-us]” as one of the Languages, and shift the preferred language to the top.

For Firefox:

a.      Tools à Options

b.      Go to “Advanced”/”Content” Tab (depends on different Firefox version)

c.       Click “Edit Languages”.

d.      Select “English (United States) [en-us]” as one of the Languages, and shift the preferred language to the top.

Notes:

This is not a Vista-related issue. It will happen in all platforms and browsers.

 


Last Modified 6/9/2010.
https://support.trustwave.com/kb/KnowledgebaseArticle13757.aspx