Some recipients of large distribution lists do not receive emails


This article applies to:

  • MailMarshal Exchange 5.3.X

Symptoms:

  • Some recipients of large dynamic distribution lists do not receive list emails

Causes:

  • With large dynamic distribution lists, the email could be split ("bifurcated") into two or more copies.
  • MailMarshal Exchange will see the additional copies as duplicates, and discard them.

Resolution:

In MailMarshal Exchange release 5.3.2 and above, to ensure that the messages are delivered to all recipients, you can add a Registry setting.

Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Trustwave cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Make sure that you backup your Registry prior to making any changes.

  1. On the affected server, open the Registry Editor.
  2. Navigate to HKEY_LOCAL_MACHINE | SOFTWARE | Wow6432Node | Marshal Software | MailMarshal for Exchange | Default | ExchangeAgent
  3. Create a new value with the following properties:
    • Type: DWORD
    • Name: KeepDuplicates
    • Data: To retain the duplicate messages and ensure that all recipients receive the distribution list email, set this value to 1. To discard duplicates, set it to 0. Default (if the value is not present): 0.
  4. Restart the MailMarshal Exchange Engine service.

Last Modified 4/19/2010.
https://support.trustwave.com/kb/KnowledgebaseArticle13730.aspx