Some Flash/Audio applications get stuck


  • Description
    Some Flash or audio/video content on a web page may not load.

  • Symptoms

    In situations like this, controls for a player application might appear on the web page, but the media content will not play.  The transaction logs in the Finjan web interface (Logs and Reports -> View Web Logs) will not show any blocks related to the media content.


  • Cause

    Some large media files (for example, MP3 files) might trigger the Download Status Page, even though the default "Allow Streaming" rule prevents this in many situations.  The status page is sent to the client in the background.  This could confuse the Flash or audio/video player, which is expecting media content.


  • Solution
    The Download Status Page can be disabled for specified file extensions or MIME types.  These settings can be found at different locations within the Finjan policy management web interface, depending on the VSOS version.

    8.x: Settings -> Miscellaneous -> Status Page

    9.x: Administration -> System Settings -> Scanning Options -> Activate


    Screenshot: Adding a Download Status Page exception in VSOS 9.x


    As a quick test to determine whether this solution applies, the status page can be disabled by unchecking the "Enable Status Page" checkbox, saving, and commiting.  Be sure to wait for the commit to finish on all devices and be sure to clear any applicable caches before attempting to download the content again.  Please note that this is a global change, so it should be done at a time when it is unlikely to affect normal usage.

    A packet trace can be used to isolate file extensions or MIME types for which the status page must be disabled.  Captures can be performed on the client machine or on the Finjan appliance itself.  File extensions can be seen by simply looking at the name of the file in the client's GET request.  MIME types can be identified by looking for the Content-Type header in the server's response.

  • Software Version
    9.0
    9.2

  • This article applies to:
    NG 1000
    NG 5000
    NG 6000
    NG 8000
    This article was previously published as:
    Finjan KB 12676

    Last Modified 12/23/2009.
    https://support.trustwave.com/kb/KnowledgebaseArticle13675.aspx