Some static routes are not being processed


  • Description
    Setup Console stops processing static routes at illegal route entries.

  • Symptoms
    Only part of the configured static routes are active.

  • Cause
    Static routes configured in the Setup Console are added one by one to the OS.
    When there is an error in the configured routes, for example a typo or a mismatch between network ID and netmask, the GUI will stop parsing further routes.
    If you have multiple static routes then only the routes listed above the faulty ones are activated.


  • Solution
    Make sure you don't have any typos or other errors (network_id / netmask mismatch) in the configured routes.
    To simplify the debugging, add each route one by one and watch each route getting activated. You will find the error when an added route doesn't become active.

  • Software Version

    8.4.0
    8.4.3
    8.5.0


  • This article applies to:
    NG 1000
    NG 5000
    NG 6000
    NG 8000
    This article was previously published as:
    Finjan KB 1548

    Last Modified 3/23/2009.
    https://support.trustwave.com/kb/KnowledgebaseArticle13395.aspx