Juniper SSL VPN fails to connect with Finjan SSL Appliance


  • Description
    When deploying a Finjan Vital Security SSL solution and requiring the tunnelling of Juniper SSL VPN connections through the solution, Finjan cannot scan the traffic going through the Juniper SSL VPN.

  • Symptoms
    The connection fails constantly.

  • Cause
    This is due to the traffic stream of mixed protocols which the scanning engines cannot handle.

  • Solution
    To make a Juniper VPN connection work through an SSL/NG appliance pair, you must add the full domain name to the URL List in the Policies Section of the SSL appliance configuration. If wild cards are used, for example *.capita.co.uk then this can cause a certificate miss-match and again the connection will fail.


  • Software Version
    N/A

  • This article was previously published as:
    Finjan KB 1528

    Last Modified 3/23/2009.
    https://support.trustwave.com/kb/KnowledgebaseArticle13378.aspx