Scanning Server fails to Commit / stuck in Committing Status


  • Description
    A repetitive "Commiting..." issue occurs when a scanning server is being managed by more than one Policy Server.

  • Symptoms
    The symptoms are seen from the following window of the Policy Server management module under Settings -> Devices -> Scanner's IP -> Committing Status and Device configuration revision:
    1. The Committing Status will be set to "Commitiing..."
    2. The Scanning Server's "Device configuration revision" will change.
    3. The Scanning Server's Commiting Status will then start the commit process again (Step 1-3).
      These 3 steps will constantly happen in a loop.

    This loop shows that the scanner is being controlled by two (or more) separate Policy Servers.
    The "Device Configuration Revision" will match the configuration revision number of the first Policy Server and then the other Policy Server/s.


  • Cause
    The cause of this issue is that two or more Policy Servers have been configured to manage the affected scanning server/s.

  • Solution
    There are 2 optional solutions for this issue:

    Solution 1
    Remove the affected scanning servers from the configuration of one of the controlling Policy Servers, leaving only one Policy Server to manage the scanning server/s.

    Solution 2
    Switch off one of the Policy Servers, or disconnect from the LAN, and then re-configure outside of the environment.

  • Software Version
    8.3.x

  • This article applies to:
    NG 1000
    NG 5000
    NG 8000
    This article was previously published as:
    Finjan KB 1363

    Last Modified 3/23/2009.
    https://support.trustwave.com/kb/KnowledgebaseArticle13254.aspx