Java Applets do not work even if whitelisted and cache is emptied


  • Description
    Java applets do not work, even after whitelisted and the java cache is emptied .

  • Symptoms
    Java Runtime Environment fails when running java applets.
    All relevant URLs are whitelisted and the requests are seen as allowed in the Vital Security NG log.

  • Cause
    Due to the size of some java applets the status progress page is invoked and shown to the Java Runtime Environment client (JRE) during download and scanning of the applet.
    This causes the JRE to store an invalid applet or abort the execution prematurely.

  • Solution
    Prevent the status page from being shown to java clients downloading java content.
    This can be done by adding the keywords java and jar to the list that prevents activation of the status page in the Management Console under Settings -> Miscellaneous -> Status Page -> Don't Activate if Content Type includes following Substrings (separated with commas).



  • VSOS
    8.3.x
    8.4.x
    8.5.0

  • This article applies to:
    NG 1000
    NG 5000
    NG 8000
    This article was previously published as:
    Finjan KB 1357

    Last Modified 3/23/2009.
    https://support.trustwave.com/kb/KnowledgebaseArticle13250.aspx