What causes a blank page through Vital Security NG Proxy? - Internal


  • Description
    When using Internet Explorer and working through the Vital Security NG appliance the website is displayed as a blank page.
    The browser appears to be transferring data, but the final result is an empty page.

  • Symptoms
    Browse to the following URLs to reproduce this behaviour:
    www.jobsearch.lu
    www.tui.de

  • Cause
    This behaviour can be analyzed with the network traffic capture. 
    It will show HTTP 205 Reset Content message sent back from the server. 

    RFC 2068 Clause 10.2.6 - 205 Reset Content
    "The server has fulfilled the request and the user agent SHOULD 
    reset the document view which caused the request to be sent. 
    This response is primarily intended to allow input for actions to take 
    place via user input, followed by a clearing of the form in which the 
    input is given so that the user can easily initiate another input action. 
    The response MUST NOT include an entity."

    • However, IE accepts a HTTP 205 Reset Content response with a body and displays a page.
    • The Vital Security NG proxy does not forward the corresponding body, and the page is not displayed. 
    • IE behaves abnormaly, when it answers the request with a HTTP 205 Reset Content status.
    • Mozila Firefox is answered with a standard 200 OK response.


  • Solution
    Use Mozilla browser to override this behaviour or contact your web-server administrator to update 205 Reset Content response.

  • This article applies to:
    NG 1000
    NG 5000
    NG 8000
    This article was previously published as:
    Finjan KB 1194

    Last Modified 2/3/2010.
    https://support.trustwave.com/kb/KnowledgebaseArticle13138.aspx