Pre-fetching requires internet access


  • Description
    The prefetching mechanism is responsible for "grabbing" all relevant modules which are refered to as external modules from the internet. This is done with a clientless request (only if the modules are not yet present in the Fetcher).

  • Symptoms
    A customer may encounter multiple issues if the scanners were not configured to have access to the internet.
    • ICAP errors (when the gateway is an ICAP client such as Blue Coat or Netcache).
    • Scanning latency
    • Multiple timeouts on browsing
    • Unscannable content.

  • Cause
    As described above, part of the scanning process includes pre-fetching which requires direct access to the internet. If the scanners do not have direct access to the internet the prefetching mechanism will not be able to perform its tasks.

  • Solution
    1. Enable scanner internet access on the network topology (e.g. Firewall allows the scanners to access the internet).
    2. If there is no direct Internet access, in order to perform prefetching of Java classes for Applet scanning, ALL Scanning Servers must have the next proxy configured.



    3. If you are using ICAP, ensure that the NG Appliance Scanning Server appears on the Access List.
  • Software Version
    8.3.x
    8.4.x

  • This article applies to:
    NG 1000
    NG 5000
    NG 8000
    This article was previously published as:
    Finjan KB 1142

    Last Modified 3/23/2009.
    https://support.trustwave.com/kb/KnowledgebaseArticle13101.aspx