Delivery Status Notifications not processed


This article applies to:

  • MailMarshal Exchange 5.2.x and below
  • Exchange 2000 or Exchange 2003
  • This issue and resolution DOES NOT apply to MailMarshal Exchange 5.3 (Exchange 2007)

Symptoms:

  • Delivery Status Notification emails (or other messages with this text in the subject line) are not processed by MailMarshal Exchange

Causes:

  • This behavior is by design

Resolution:

 If you want to scan these messages with MailMarshal Exchange:

  1. Upgrade to MailMarshal Exchange 5.2.1 or above (for Exchange 2000/2003)
  2. Add a registry entry. 
    • Open the Registry Editor.
    • Navigate to:
      HKEY_LOCAL_MACHINE\SOFTWARE\Marshal Software\MailMarshal for Exchange 
    • Create a new value with the following properties:
      Type: DWORD 
      Name: DSNAnalysisEnable
      Data: 1

Notes:

Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Trustwave cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved.

Make sure that you back up your Registry prior to making any changes.


Last Modified 11/23/2009.
https://support.trustwave.com/kb/KnowledgebaseArticle12945.aspx