MailMarshal services fail due to missing DLL


This article applies to:

  • Trustwave MailMarshal (SEG)/SEG
  • WebMarshal
  • VMWare environments

Problem:

  • Marshal product services stop or fail to start
  • Virus scanner and SQL Server services may also be affected
  • Sample event log or engine log error messages:
    Classifier Library failed to load dll NodeConfig\SpamCheckerBridge.dll
    Configuration Proxy failed to create an IConfiguration interface

Cause:

  • Upgraded VMware tools.
  • VMware uninstallation removes the file msvcp71.DLL which is part of the Visual C++ redistributable. Some Marshal product executables depend on the Visual C++ DLLs.
    • VMWare acknowledges this issue with upgrade from from 3.5 to 4.0; however, the issue is also reported from the field with later versions.
  • Certain other software installations or upgrades have also been reported to cause this issue.
  • The issue may not manifest until the server is restarted.

Resolutions:

To resolve this issue, you can

  1. Locate a copy of the file msvcp71.DLL and place it in the appropriate system folder on all affected systems.
    • For 32 bit Windows systems or SEG 8.X and above, use the \Windows\System32 folder.
    • For earlier SEG versions on supported 64 bit Windows systems (such as Server 2008 64 bit), use the \Windows\SysWOW64 folder.
    • You may be able to copy this file from another system in your network
    • You may be able to download a copy from websites such as http://www.driverskit.com/ or http://www.dll-files.com/
      • Caution is advised when downloading files from such sites.
  2. Restart affected services and applications.

If the above resolution does not work:

  1. Back up MailMarshal or WebMarshal configuration.
  2. On each affected system, run the product installer in Repair mode.
  3. If necessary, restart systems.
  4. If necessary, restore configuration (however, in general this step should not be required).

Notes:

  • This issue is reported to affect operation of many software packages including SQL Server, virus scanner software, and others.
  • Trustwave thanks a customer for reporting the problem and resolution.

Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle12929.aspx