This article applies to:
- Trustwave MailMarshal (SEG) (legacy 32 bit versions)
Symptoms:
- MailMarshal performance counters cannot be selected in Windows Performance Monitor
- MailMarshal performance counter information is zero or blank
Causes:
- After upgrade, the MailMarshal Performance Monitor DLL could not be registered.
Resolution:
To register the DLLs, on each server where the problem occurs do the following:
- Click Start > Run
- Enter:
regsvr32 "E:\Program Files\Marshal\MailMarshal\MMPrfMon.dll"
(substitute the location of your MailMarshal SMTP installation)
- The response should be "DLLRegisterServer in MMPrfMon.dll succeeded"
- Counters should be available.
- If counters are not available, restart MailMarshal services and check again.