This article applies to:
- Trustwave MailMarshal (SEG)
- Trustwave ECM/MailMarshal Exchange 7.X
Symptoms:
- MailMarshal Engine, Sender and Receiver (depending on product) will not start
- MailMarshal Controller log shows group not found errors
- Sample error: CGroupManager: failed to retrieve group from Array Manager: Get group [contoso.com/Users/_Reimbursement] failed: Group not found
Causes:
- A MailMarshal rule, or a group configuration exclusion such as DOS/DHA, references a user group that does not exist.
- Typically the missing group is an Active Directory or LDAP imported group.
Resolution:
To determine the rule or item causing the issue, review the Controller log.
Consider the following log:
0772 17:54:28.580 [Archive All Inbound Messages]
0772 17:54:28.580 [Archive All Outbound Messages]
0772 17:54:28.580 ** [contoso.com/Users/_Area 1] ** (up to date).
0772 17:54:28.580 ** [contoso.com/Users/_Area 2] ** (up to date).
0772 17:54:28.580 ** [contoso.com/Users/_Area 3] ** (up to date).
0772 17:54:28.580 ** [contoso.com/Users/_Area 4] ** (up to date).
0772 17:54:28.580 ** [contoso.com/Users/_Area 5] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_Area 6] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_Area Sales Managers] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_HCH Claims] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_Collections] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_Customer Contact Centre] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_Executive] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_Extras] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_Finance] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_Financial Management] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_Financial Planning] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_Human Resources] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_Information Services] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_Sales Advisors] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_Marketing] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_PN Claims] ** (up to date).
0772 17:54:28.596 ** [contoso.com/Users/_Product & Underwriting] ** (up to date).
0772 17:54:28.596 CGroupManager: failed to retrieve group from Array Manager: Get group [contoso.com/Users/_Reimbursement] failed: Group not found
0772 17:54:28.596 Event - Configuration: Error retrieving groups: Get group [contoso.com/Users/_Reimbursement] failed: Group not found
Here we see that Archive all outbound messages is the last rule. The group not found error occurs after the last rule. This indicates a problem with DHA exclusions. The DHA group setup contains the groups that cannot be found.
If the group not found error occurred immediately after the name of a rule earlier in the log, the group not found error would be related to that rule.
To correct the issue, edit the appropriate rule or exclusion, and select a valid group.
Notes:
Best practice is to always reference MailMarshal groups in the rules or exclusion settings (not imported groups).
This practice will avoid service stop problems with imported groups that are deleted at the source. MailMarshal performs consistency checking on local groups and does not allow groups to be deleted if they are in use.