Exchange Test-Mailflow cmdlet fails


This article applies to:

  • Trustwave ECM/MailMarshal Exchange
  • Exchange 2007 

Symptoms:

  • The mailflow test cmdlet fails when MailMarshal Exchange is in use with Exchange 2007 
  • SCOM shows alerts or events

Causes

  • Test mail to the Exchange System mailbox is blocked by MailMarshal Exchange

Resolution:

To resolve this issue, add the Exchange System mail box address to the MailMarshal Exchange address bypass list.

Because the mailbox address is specially formatted, you cannot add this address through the MailMarshal Exchange Configurator, but you can add it by editing the registry.

  1. Open Regedit.
  2. Navigate to the following registry location: 


    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Marshal Software\MailMarshal for Exchange\Default\ExchangeAgent 

  3. Edit the value BypassAddresses
  4. Enter the required address
    • the address will be similar to
      SystemMailbox{5BA76078-AC22-42CA-B3FC-735FD085C1CF}@contoso.com
  5. Restart the MailMarshal Exchange Agent service

Note:

As always, take due care when editing the Registry.


Last Modified 7/15/2009.
https://support.trustwave.com/kb/KnowledgebaseArticle12891.aspx