AD Agent using too much CPU (50-99%)


This article applies to:

  • R3000
  • AD Agent 

Symptoms:

  • When looking at the CPU usage for the main AD Agent process, 8e6dcagent.exe, it is running extraordinarily high - anywhere from 50-99% CPU usage.

Causes:

  • This is generally caused by a corrupt file in the mbox and/or spool directories in the Agent's folder.  It will max out CPU usage when it continuously tries and fails to process this corrupted file.

Resolution:

In most cases, simply stopping the service, deleting the contents of the spool and mbox directories, and restarting the service will resolve this issue.  Note that deleting the contents of the spool directory will erase the contents of the Sessions tab in the Agent, but it will re-run log scanning and repopulate this info when the service is restarted.


Last Modified 6/22/2009.
https://support.trustwave.com/kb/KnowledgebaseArticle12804.aspx