This article applies to:
- Marshal Reporting Console
Symptoms:
- On screen report delivery times out
- On screen report delivery gives error "Out of memory"
- Printed reports fail due to timeout or memory condition on printer
- Excel exports (SQL 2008 R2 reporting server) fail with error message: Number of rows in the Excel sheet exceeded the limit of 65536 rows
Causes:
- The requested report returns a very large amount of data. The time to process data exceeds a system timeout, or the size of data returned is too large for the configured delivery method.
- Excel worksheets are limited to 65536 rows (by the design of Excel).
- The XLSX format allows a greater number of rows. This format is available when you use MRC 2.6 or above with the latest SQL Server versions. All report formatting and exporting from MRC depends on SSRS.
Resolution:
-
If you require a report that returns a very large result set, select delivery to a file in PDF or MHTML format (not Excel).
-
If possible, reduce the data scope or period reported on.
-
Use a 64 bit licensed (full) version of SQL Server and SQL Server Reporting Services, rather than SQL Express. SQL/SSRS allows MRC to take advantage of the SSRS Snapshot feature, allowing faster and more efficient viewing of reports.
-
If you encounter the ASP.NET exception "execution timed out" while rendering a report to the screen, you can increase the allowed execution time:
- On the MRC server, navigate to the MRC installation folder (by default, C:\Program Files (x86)\Marshal\Marshal Reporting Console)
- Edit the file web.config
- Within the section system.web locate or add the element httpRuntime
- Add or edit the attribute executionTimeout
The following WebMarshal reports are particularly liable to encounter these issues:
- URL Browsing by Site
- URL Browsing by User
However, the issue can occur with any report if the requested scope or data set is large enough.