MailMarshal SMTP services will not start


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

  • Application event: Invalid user criteria: Property 'UserGroupData' was not found.
  • Marshal services will not start. 

Causes:

  • Trustwave MailMarshal (SEG) user group(s) are not pointing to the correct class identifer or are corrupt.

Resolution:

Review the MMController text log which may give you an indication of which group is not linked. 

If you can identify the problem group, correct entries in that group.

Otherwise, try each of the following (in order from least to most disruption). After each change, commit configuration and attempt to start services.

  • Check all rule user entries for items that contain a semi-colon ( ; ). Remove any ; that are found.
  • Restore your MailMarshal SMTP installation to a recent back up. See the MailMarshal SMTP User Guide for more information.
  • Delete all the Active Directory User Groups and reinstall them. You will need to disable any rules, including DHA and DoS configuration that reference the User Groups until you re-import them.
     

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle12234.aspx