Browser security settings affect Reporting Console function


This article applies to:

  • Marshal Reporting Console
  • Internet Explorer

Symptoms:

  • Error messages indicating scripting is not supported
  • Buttons or other page controls do not work

Causes:

  • Marshal Reporting Console uses active scripting (JavaScript) for browser-based controls
  • Internet Explorer (or whatever browser is in use) on the workstation is configured to disallow active scripting
  • Browsing from a Windows Server with Internet Explorer Enhanced Security Configuration enabled can disable scripting

Resolution:

To ensure that you can use the Marshal Reporting Console website, set your browser to allow active scripting. The following details apply to Internet Explorer:

  • Browse from a workstation, not the server. By default Windows Server enables IE Enhanced Security Configuration, which prevents use of active scripting.
  • Ensure that the MRC site is in a security zone that allows active scripting, such as the default Local Intranet security zone.
  • By default, the Local Intranet zone consists of local domain names in addition to any domains that are specified to bypass the proxy server. For more information about configuring the Local Intranet zone, see the Microsoft document Setting Up Security Zones.

To set the security level for the Local Intranet zone:

  1. On the Tools menu of Internet Explorer, select Security Options.
  2. Click the Security tab.
  3. Select Local intranet.
  4. To apply the defaults, click Default Level.

Note:

You can deploy Internet Explorer settings to all users by configuring Windows group policy.

 


Last Modified 3/15/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle12090.aspx