This article applies to:
Symptoms:
- Email addresses starting with # character cannot be saved in MailMarshal SES user groups
- For instance:
- some#body@example.com can be used
- #somebody@example.com cannot be used
Causes:
- MailMarshal SES stores user group information in the UserGroups.txt file
- The # character marks a comment line in the file
Workaround:
If you need to use email addresses starting with # in MailMarshal SES user groups, you can apply a Registry setting.
- On the MailMarshal SES server, run Regedit.
- Navigate to the following key:
HKey_Local_Machine\Software\Marshal\SecureEmailServer\Default
- Add a DWORD value: NoHashAsCommentInUserFile
- Set the value to 1.
- To apply the change, restart the MailMarshal SES services.
As always, take due care when editing the Registry. Trustwave recommends that you make a backup before applying any changes.
Notes:
Before you apply this registry setting, ensure that the UserGroups.txt file does not contain any comment lines marked with #