Problems due to changed time


This article applies to:

  • Trustwave MailMarshal (SEG)

Question:

  • What do I do if the date on my MailMarshal SMTP server has been changed?

Cause:

The time on the MailMarshal SMTP server has been changed to a future date.

Symptoms:

  • You may not be able to view some of the messages in the console
  • Some messages may be in the wrong location
  • Folders have incorrect names

Resolution:

NOTES:

  • It is important you have backed up the file called SequenceFile which is found in the MailMarshal installation directory
  • It is important to back up your database
  • If you need assistance with the instructions below, do not hesitate to contact Trustwave Technical Support
  1. Back up your MailMarshal database and the SequenceFile file found in the installation directory of each MailMarshal node and the Array Manager server.
    • For full details of alternate install locations see Trustwave Knowledgebase article Q10832.
  2. Stop the MailMarshal ArrayManager, MailMarshal Sender and MailMarshal Receiver services.
  3. On the MailMarshal nodes and the MailMarshal Array Manager server delete the file called SequenceFile.
  4. Start the MailMarshal ArrayManager, MailMarshal Sender and MailMarshal Receiver services.
  5. Open SQL Server Management studio and perform the following query against your MailMarshal database: update folder set oldestmessage='1/1/1970 12:00:00AM'.
  6. Restart the MailMarshal ArrayManager service.

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle12069.aspx