Authorization failed for ''company\admin''. A problem occured during authentication: Could not resolve Active Directory path - 0x80070005 - access is denied


This article applies to:

  • Trustwave MailMarshal (SEG) 6.X or 7.X Spam Quarantine Management website
  • Trustwave ECM/MailMarshal Exchange 7.X Quarantine Management website

Symptoms:

  • SQM or QM website not functioning.
  • When attempting to log on to the console: Authorization failed for 'company\admin'. A problem occured during authentication: Could not resolve Active Directory path - 0x80070005 - access is denied

Causes:

  • The Array Manager service is configured to use an account other than the Local System account. The account used by Array Manager does not have permission to access Active Directory. 

Resolution:

To resolve this particular issue, you can configure the MailMarshal Array Manager service to use the LocalSystem account, or grant the domain account appropriate permissions to browse Active Directory.

This issue could come up because in MailMarshal SMTP 6.7 and below, the Array Manager might need to use a domain account in order to obtain updates through a web proxy server. Current supported versions of the product do not have this requirement.

To configure the MailMarshal Array Manager service to use the local system account, follow the steps below:    

  1. Start Services.msc (Click Start > Run, and enter Services.msc).
  2. Browse to the MailMarshal Array Manager Service, right click and select Properties.
  3. Select the Log On tab and select LocalSystem account.
  4. Apply the changes and restart the MailMarshal Array Manager service.

Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle11968.aspx