The client and server cannot communicate, because they do not possess a common algorithm.


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

  • Error Message: The client and server cannot communicate, because they do not possess a common algorithm.
  • Cannot update SpamCensor

Cause:

This issue can be caused when the Array Manager server has the local security policy FIPS compliant algorithms enabled. FIPS is a US government policy that requires certain settings for HTTPS connections.

Resolution:

Many recent versions of SEG are able to communicate with the required website when FIPS compliance is enabled. The first option is to upgrade.

 

If you disable the requirement of FIPS compliant algorithms, the SpamCensor updates will be successful. Follow the steps below to disable this setting:

  1. On the system where the Array Manager is installed, navigate to Control Panel.
  2. Select Administrative Tools and then Local Security Policy.
  3. Navigate to Local Policies and Security Options.
  4. Double click System Cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing.
  5. Disable the setting, and then click Apply.
  6. Restart the MailMarshal Array Manager service.

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle11849.aspx