550 Your HELO string is incorrect


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms

  • When trying to send an email, you receive the error (SMTP response): 550 Your Helo string is incorrect

Causes

  • This issue can be caused by the sending MailMarshal server using a bare server name for the HELO greeting (for instance MYSERVER instead of MYSERVER.mydomain.com)
  • The server name used for HELO should be routable over the Internet, so it should include a domain name.

Resolution:

It is best practice to assign the sending machine a primary domain name.

  1. On the sending machine, open Server manager and view properties of the local server (in some earlier Windows versions, click on My Computer and select Properties).
  2. Select the Computer Name tab and click Change.
  3. Select More and in the Primary DNS suffix of this computer field, enter in the domain under which the server is a member.
  4. Click OK and OK again to exit System Properties.
  5. Restart the machine.

Note:

See the following Trustwave Knowledgebase article for another option:

  • Q10259: How do I change the MailMarshal HELO name?

Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle11709.aspx