MailMarshal Engine stops with faulting module SpamChecker.dll


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms

  • MailMarshal Engine stops
  • Event log shows faulting module SpamChecker.dll

Causes

  • This error indicates a problem with one or more of the "category script" XML files.

Resolution

To find the problem file:

  1. Remove any custom XML file inclusions.
  2. Remove any custom rule conditions that use the rule condition "Where messages is categorized as..."
  3. Commit configuration and ensure that the engine can process messages.
  4. Add the conditions or file inclusions to the configuration one by one, commit configuration, restart the engine and check that the engine will process messages. If the engine stops, the last XML file you added is likely to be the cause. Review the offending file for malformed XML or incorrect syntax.

 


Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle11704.aspx