Unable to add alternate e-mail address in SpamConsole


This article applies to:

  • Trustwave MailMarshal (SEG) Spam Quarantine Management website
  • Trustwave ECM/MailMarshal Exchange 7.X Quarantine Management website
  • Forms (Email Address and Password) authentication

Symptoms:

  • When confirming an alternate e-mail address for the SQM or QM end user management website, you encounter the following error:
  • Error: VerifyAlias. Database Procedure Failed. User '<alternate email address>' already uses email address '<login email address>'

Causes:

When using Forms authentication to access this website, you cannot add an alternate e-mail address that is already the primary address associated with a login. For example, if one user registers the login someuser@marshal.com with the SpamConsole, a secondary user with the login anotheruser@marshal.com cannot add someuser@marshal.com as one of its alternate e-mail addresses.

Reply:

This behavior is by design. In order to resolve this conflict, the conflicting login must be removed.

In current versions, users can be removed through the Administrator tab of the SQM or QM website.

The user created when SQM was installed was granted the administrator permission. 

Permissions may have been edited. If you need assistance to determine the administrator login(s), contact technical support.


Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle11703.aspx