This article applies to:
- Trustwave MailMarshal (SEG) 6.X or 7.X Spam Quarantine Management website
- Trustwave ECM/MailMarshal Exchange 7.X Quarantine Management website
- Forms (Email Address and Password) authentication
Symptoms:
- When confirming an alternate e-mail address for the SQM or QM end user management website, you encounter the following error:
- Error: VerifyAlias. Database Procedure Failed. User '<alternate email address>' already uses email address '<login email address>'
Causes:
When using Forms authentication to access this website, you cannot add an alternate e-mail address that is already the primary address associated with a login. For example, if one user registers the login someuser@marshal.com with the SpamConsole, a secondary user with the login anotheruser@marshal.com cannot add someuser@marshal.com as one of its alternate e-mail addresses.
Reply:
This behavior is by design. In order to resolve this conflict, the conflicting login must be removed.
MailMarshal SMTP 6.4 and above, MailMarshal Exchange 7.X:
In current versions, users can be removed through the Administrator tab of the SQM or QM website.
MailMarshal SMTP versions below 6.4:
The user must be removed from the User and UserAlias tables within SQL manually. In the example above, if you wished to associate someuser@marshal.com with the anotheruser@marshal.com login, you would do the following from your SQL server:
C:\Documents and Settings\root\Desktop>osql -E
1>use MailMarshal
2>go
1>delete UserAlias where emailaddress='primaryuser@marshal.com'
2>delete [user] where username='someuser@marshal.com'
3>go
NOTE: You should replace MailMarshal above with the name of the database used by your MailMarshal installation
The user logging in as anotheruser@marshal.com should now be able to add someuser@marshal.com as one of their alternate e-mail addresses through the normal channels.