Available Category Scripts do not display in Rule Wizard


This article applies to:

  • Trustwave SPE/MailMarshal SPE

Symptoms:

  • Category Script XML files are present in the Config folders of SEG
  • In Standard rules > Rule wizard > Conditions > Where message is categorized as category > Parameters, no Category Scripts are available for selection.

Causes:

Creating an array policy or customer package to use a category script requires that all arrays managed by SPE have a common set of category scripts available for selection.

The presence of category script on each array is checked by the SPE agent using the schedule configured under Arrays->Advanced->General.

If an array is not validly configured for any reason, no category scripts will be available for that array.

Because SPE has flagged that the scripts do not exist on all arrays, no category scripts will be available for selection.

  • For instance, the array could have been configured with invalid credentials.

Resolution:

To resolve this issue, follow one of the steps below:

  1. Ensure that all arrays are validly configured and ensure that the replication agent has run for all arrays, before adding category parameters to rules.
  2. Wait for the period defined under Arrays->Advanced->General->Category Update Interval
  3. Press the "Update Now" button under Arrays->Advanced->General tab for each array. Within 60 seconds, the replication agent will update the list of available category scripts for that array.

Note:

If a single script is not available, check that the related file is present on all arrays.


Last Modified 11/10/2011.
https://support.trustwave.com/kb/KnowledgebaseArticle11621.aspx