Delivery Status Notifications (Delivery Receipts) do not contain any information about the emails they are for.


This article applies to:

  • MailMarshal Exchange 5.1.x

Symptoms

  • Delivery Status Notifications (Delivery Receipts) do not contain any information about the emails they are for.

Causes

  • The problem occurs when emails are sent via an X.400 connector that is running through a relaying server. 
  • MailMarshal Exchange breaks the receipt mechanism (Delivery Status Notification) by damaging the corresponding email. These receipts (Through the use of Transaction ID's) confirm a message has been delivered to the emails intended recipients successfully.
  • When MailMarshal Exchange scans an email, it removes it from the Mail Delivery queue, but when it places it back into the queue so it can be delivered, it is given a different transaction ID. This means when a Delivery Status Notification is sent back to the original server it is blank.    

Resolution:

Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Marshal cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Make sure that you backup your Registry prior to making any changes.

There are two fixes available for this problem. Follow the steps detailed below.

Fix 1 - Change the Format of the Delivery Receipt (This is done by adding a new registry key to each Exchange server that is affected.)
This fix changes the format of the delivery receipt and includes the original email as an attachment in the receipt itself. This prevents the originating server having to check the delivery receipt matches the email delivered as the email is contained with the receipt.

  1. Start Regedit (Click Start > Run, and enter Regedit).
  2. Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent
  3. Create a new DWORD value RenderDSNsAsMessages and set it to 1.
  4. This will turn the entry on. To turn it off change the value to 0.

    Note: This change will increase the size of the delivery receipts as the email's are now attached to them as well. You can limit the size of the delivery receipts. This is done by adding the following key to the registry. (If you don't want to limit the size of the receipts, click ok, and exit regedit.)
  5. Now navigate to:
    HKLM\System\CurrentControlSet\Services\SMTPSVC
  6. Add a new key and name it Queuing.
  7. Within Queuing, add a DWORD called MaxDSNSize. The value you enter within MaxDSNSize is the max size, in bytes, the delivery receipts will be.
  8. Click OK, and exit regedit.

Note: After completing the steps it is important to restart the IIS Admin service.

Fix 2 - Repair the Notifications (Note: This fix requires the message logs on the exchange server to be turned on.)
An alternative fix to the option described above is to repair the notifications themselves. This is done by using the Message Tracking logs on the exchange server. If the messages have passed through a relay then the receipt will be incorrect and will need to be repaired. To use this method of repair follow the steps detailed below. (Note: As the Message Tracking Logs are being used in this fix, at the exchange server, they need to be turned on.)     

  1. Start Regedit (Click Start > Run, and enter Regedit).
  2. Navigate to: HKEY_LOCAL_MACHINE\SOFTWARE\Marshal Software\MailMarshal For Exchange
    (Note: Not MailMarshal Exchange)
  3. Create a new DWORD value called, EnableMEX-6 and turn it on by setting the value to 1.
  4. Click OK, and exit regedit.

Note: After completing the steps there is no need to restart any services.

Notes:

Please also see KB article:

Q11556 : Why are read receipts in MailMarshal Exchange sometimes not received or are blank.


Last Modified 3/19/2007.
https://support.trustwave.com/kb/KnowledgebaseArticle11543.aspx