This article applies to:
- Trustwave SEG/MailMarshal
- Trustwave ECM/MailMarshal Exchange 7.X
Symptoms:
Event ID: 3004
Type: Error
Source: MMArrayManager (MailMarshal SMTP) or MEXArrayManager (MailMarshal Exchange)
Description: MailMarshal Array Manager Cannot Connect to the MailMarshal Database
Causes:
This event is raised whenever the MailMarshal Array Manager is unable to connect to its configured database.
Resolution:
To resolve this issue:
- Determine the server name, instance name (if any) and database name of the existing MailMarshal database.
- Determine a valid credential (SQL login and passsword, or Windows domain\login and password) that MailMarshal can use to connect to the database.
- Ensure that SQL connetivity is available between the Array Manager server (or standalone MailMarshal server) and the database server. (Use named pipes or TCP/IP).
- Use the Server Tool, on the Array Manager server, to verify the database connection.