WebMarshal Engine fails to start after installation: can't connect to database


This article applies to:

  • WebMarshal 

Symptoms:

  • New WebMarshal installation/configuration
  • WebMarshal Engine does not start when the configuration wizard is completed
  • Error: Cannot contact database, installation cannot continue 

Causes:

These symptoms can occur when

  • The SQL Server is a named instance
  • "Connect using TCP/IP" is not selected on the database settings window of the wizard.
  • TCP/IP is required for connectivity due to the network environment

Resolution:

To resolve this issue, in the configuration wizard go back to the database window (or restart the wizard and proceed to this window). Select "connect using TCP/IP," then complete the wizard. 

Notes:

This problem has only been observed when all three causes are present.


Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle11456.aspx