3507 - Failed to open connection (MMSender errors)


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

Windows Event Log entry

Event ID: 3507
Type: Error
Source: MMSender
Description: Failed to open connection

Causes:

The MailMarshal SMTP Sender service was unable to open a connection to the remote host.

This event will be raised when there is no connectivity between the MailMarshal server and the remote host.

  • This event is typically caused by a generic network issue.
  • Another possible cause is incorrect DNS records, which can cause the MailMarshal Sender to attempt to connect to the incorrect host for a particular domain.

Resolution:

If this error occurs, check basic network connectivity from the MailMarshal server to the remote host on TCP port 25, and verify that the DNS MX record (mail exchanger) returned for the domain is correct.

Notes:

In array installations, this event could occur only on some nodes if MailMarshal is configured to bind to a specific IP address. 

For details about setting sender bindings, see Trustwave Knowledgebase article Q10034

This article supersedes:
NETIQKB46711
Q10668

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle11443.aspx