This article applies to:
- Trustwave MailMarshal (SEG)
Symptoms:
Event ID: 2502
Type: Warning
Source: MMReceiver
Description: DNS error
Causes:
This warning can be logged during the host validation portion of the message evaluation, when a check that requires the use of DNS is performed. Potential causes can include:
- Error contacting a DNS RBL Blocklist
- Error validating a HELO name against a host's PTR because the HELO sent was invalid
- PTR validation is enabled, but the host does not have a PTR record
Note that none of these events is a failure in the SEG/MailMarshal software.
Resolving the Issue:
You should always be sure that you are using DNS through a reliable, local DNS server with good network connections.
To learn more about why this warning is logged, you can check the MailMarshal Receiver text log.
- If the log indicates a timeout or other failure contacting a DNS blocklist provider, you may want to disable use of that service temporarily.
- If the log indicates an error validating the HELO or PTR, this usually indicates that the remote server has a poorly configured DNS record.
- You can stop the warning by adjusting the Host Validation settings (in the MailMarshal Configurator, Array Properties > Host Validation). However, this also stops the validation check for all servers.
- Current versions of SEG include a DNS cache in the Controller service that reduces DNS load and the likelihood of DNS errors.