Why does MailMarshal Receiver report that it cannot bind to local port 25?


This article applies to:

  • Trustwave MailMarshal (SEG)

Question:

Why does MailMarshal Receiver report that it cannot bind to local port 25?

Symptoms:

  • The MailMarshal Receiver reports that it cannot bind to local port 25.
  • Error: Event - Failed to bind socket to <0.0.0.0:25>, an MTA (SMTP)-Simple Mail Transport Protocol server is probably already running (typically the Windows 'Simple Mail Transport Protocol' service) - 10048 - WSAEADDRINUSE

Causes:

The MailMarshal Receiver service is not able to bind to port 25 because another program is already bound to port 25. The WinSock layer may report that an Message Transfer Agent (MTA) service, for example, an SMTP server, is already bound to it, "10048 - WSAEADDRINUSE."  The error may occur if MailMarshal is installed on the same server as Exchange, or any other mail server.  Some anti-virus scanners, or other types of SMTP proxy, may also cause the error.

Information:

To start the MailMarshal Receiver service, the competing SMTP service must be removed, disabled, or moved to a different port. Alternatively, in rare cases you could move the Receiver to a different port.
After making changes, restart the MailMarshal Receiver service.

Notes:

See the following Trustwave Knowledgebase articles for installing MailMarshal on the same computer as Exchange.

  • Q11972: Configuring MailMarshal SMTP (SEG) to forward mail to Microsoft Exchange Server 2010 or 2007
  • Q20645: Configuring SEG with Exchange 2013 or 2016 as internal mail server
  • Q21146: Installing MailMarshal (SEG) 10.X with Microsoft Exchange
This article was previously published as:
NETIQKB36078

Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10954.aspx