Why Does a Copy of Each Email Message End Up in the Exchange Badmail Folder?


This article applies to:

  • Trustwave ECM/MailMarshal Exchange 5.0

Symptoms:

  • The original email message is delivered, but a copy of each email ends up in the Exchange badmail folder.
  • Microsoft Exchange message archiving or journaling is enabled.

Causes:

When journaling is enabled, Microsoft Exchange creates a copy of every message each time it is processed by the categorizer - one copy for delivery and one copy for the archive.  MailMarshal Exchange processes one of the copies and if it doesn't trigger on a rule, resubmits it back to Exchange for delivery.  Exchange makes another copy of the resubmitted message, leaving three messages in Exchange.  Exchange sees that two of the messages are duplicates - it delivers one copy, archives another copy and puts the third (duplicate) copy in the badmail folder.

Information:

Turn off message archiving/journaling in MS Exchange and configure MailMarshal Exchange to archive messages.

To turn off message archiving/journaling in MS Exchange:

  • On the Mailbox Store properties, disable Archive all messages sent or received by mailboxes on this store.

To archive messages using MailMarshal for Exchange:

  • Create a rule in the incoming, outgoing and internal rulesets.  The rules should look similar to this:
    Copy the message to 'Archive Folder'
    And pass the message to the next rule for processing

This article was previously published as:
NETIQKB37345

Last Modified 6/11/2008.
https://support.trustwave.com/kb/KnowledgebaseArticle10951.aspx