The Exchange Badmail directory has an increasing number of copies of the same message.


This article applies to:

  • MailMarshal Exchange 5.0

Symptoms:

  • The Exchange Badmail directory has an increasing number of copies of the same message.
  • Users are receiving duplicate copies of the same message.
  • Active Directory Forwarding is generating duplicate messages.

Causes:

MailMarshal Exchange does not support Active Directory Forwarding of messages. Turning this feature on will cause unpredictable results. This is because the Active Directory Forwarding feature occurs in Exchange during the post categorization stage (during which MailMarshal Exchange handles messages). When Active Directory Forwarding is enabled, duplicate messages with the same Exchange message ID will be inserted back into the Exchange queue by the MailMarshal for Exchange Stub, which results in the symptoms mentioned above.

Information:

Trustwave recommends you turn off the Active Directory Forwarding feature. MailMarshal Exchange has a BCC rule action which can be used to emulate this feature.

To modify the Active Directory Forwarding option:

  1. Open the Active Directory Users and Computers console.
  2. Double click on a user to open the Properties dialog for that user.
  3. Navigate to the Exchange General > Delivery Options > Forwarding Address option.

This article was previously published as:
NETIQKB38358

Last Modified 6/11/2008.
https://support.trustwave.com/kb/KnowledgebaseArticle10744.aspx