The 'MMSender', 'MMEngine', and 'MMReceiver' services on a single server MailMarshal installation will not start


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

  • The 'MMSender', 'MMEngine', and 'MMReceiver' services on a single server MailMarshal SMTP installation will not start.
  • The MMController log reports the following error: "Event - Cannot open connection Array Manager - node ping failed. Error 1722 - The RPC server is unavailable."
  • Restarting the MailMarshal services through the user interfaces generates the following error: "Failed to fetch service status: Server not online."
  • The MMController service is running, but the services will not start.

Causes:

The MailMarshal Array Manager cannot communicate with the Controller service because RPC port 19001 or 19002 is unavailable.

 

Resolution:

Ensure that ports 19001 and 19002 on the MailMarshal server are available. If MailMarshal has been configured to use non-standard RPC ports, ensure that they are available.

 

Notes:

The ports could be in use by other software, or they could be blocked by Windows Firewall or network interface filtering.

Current supported versions of SEG automatically add rules to Windows Firewall configuration to allow the required port communications.

This article was previously published as:
NETIQKB42587

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10740.aspx