SQL errors appear every 1 to 5 minutes in the event logs.


This article applies to:

  • Trustwave MailMarshal (SEG)
  • Trustwave ECM/MailMarshal Exchange

Symptoms:

  • SQL errors appear every 1 to 5 minutes in the event logs.
  • Error: 'Error accessing SQL server.'
  • Error: 'Unable to open ADO connection.'

Causes:

The SQL server used by MailMarshal may be out of disk space, or the database size may have reached the limit in SQL Express.

Information:

SQL Express has limited database sizes (up to 10GB in current versions).

If this error continues to occur you should consider purchasing a commercial version of SQL Server. The commercial versions do not have arbitrary database size limits. For suggested sizing requirements, see the User Guide for your MailMarshal product version.

As a temporary workaround, in the MailMarshal Configurator or Management Console, you can change the length of time (in days) that MailMarshal stores data. See the Logging tab (in Array Properties).

Notes:

For more information see the following Trustwave Knowledgebase article:

  • Q10403: How do I manually force a purge of a SQL or MSDE database? 
     
This article was previously published as:
NETIQKB36120

Last Modified 5/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10738.aspx