Services will not start due to Internal error 2140


This article applies to:

  • Trustwave MailMarshal (SEG)
  • Trustwave ECM/MailMarshal Exchange

Symptoms:

  • Services will not start
  • Error: 'Internal error 2140'

Causes:

This message is a generic Microsoft Windows error message simply meaning that one or more of the services were unable to start.

 

Information:

To confirm the cause of this error, check the Windows Event Log. The error may be related to irregularities in the MailMarshal Configuration. For example, a Rule may have missing information. A check of the relevant log file (for instance the Engine log) in the MailMarshal Logging directory may yield more information.

You can also try running the MailMarshal service in "debug" mode from a command prompt. This enables the user to immediately see the results of the system logging, and is especially useful when a service fails to start - often you can see why by running the service in debug mode.

  • If necessary stop the MailMarshal system services.
  • From a command prompt in the MailMarshal directory enter:

    start MMEngine -debug
To debug other services substitute the desired service name, such as:
  • MMReceiver, MMSender, MMController (MailMarshal SMTP)
  • MMEEngine, MMEController (MailMarshal Exchange 5.X)
  • MEXEngine, MEXController (MailMarshal Exchange 7.X)

This article was previously published as:
NETIQKB29679
Marshal KB24

Last Modified 3/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10719.aspx