Runtime error when trying to access the 'AdminConsole' or 'Spam Quarantine Management Console'.


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

  • Runtime error when trying to access the 'AdminConsole' or 'Spam Quarantine Management Console'.

Causes:

Microsoft .NET Framework was installed before the Microsoft Internet Information Service (IIS) components were installed. Consequently, the ASP.NET services that come with Microsoft .NET Framework were not registered with IIS.

 

Reply:

Try one or both of the following solutions. Thee first option is the simplest task to perform, and should fix the issue.

Option A

Manually register the ASP.NET services:

  1. Open a command prompt.
  2. Type "%WINDIR%\Microsoft.NET\Framework\version\aspnet_regiis.exe -i".  (Replace version in the path with the actual version number of ASP.NET in use on the system)
  3. Press Enter.

Option B

Uninstall, then reinstall Microsoft .NET Framework.

Note:

If you have other ASP.NET applications on the same server, after performing either of the above actions you should verify the operation of each.

This article was previously published as:
NETIQKB42600

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10709.aspx