PGP messages are received as an attachment


This article applies to:

  • Trustwave MailMarshal (SEG)
  • Trustwave ECM/MailMarshal Exchange 7.X

Symptoms:

  • PGP messages are received as an attachment.
  • If sending or receiving PGP messages, they are received as an attachment to a blank message with a message stamp.

Causes:

MailMarshal can detect PGP encrypted messages. Because these messages are encrypted, MailMarshal cannot unpack them to examine their contents. If a rule is not specified to block PGP messages, they will be passed through MailMarshal unchecked. 

When MailMarshal applies a message stamp to a PGP message, it cannot actually stamp the PGP part of the message. Instead, it creates a new message, stamps it, and attaches the original PGP message to the new message.

 

Reply:

Exclude PGP messages from being message stamped. Alternatively, for a solution where there is no requirement to detect PGP messages, contact Trustwave Technical Support.

This article was previously published as:
NETIQKB29234
Marshal KB148

Last Modified 5/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10680.aspx