This article applies to:
- Trustwave MailMarshal (SEG)
Symptoms:
- None of the MailMarshal services will start.
- There are no entries in the Windows event log.
Causes:
A simple way to see what is causing the services to fail on startup is to run one of the MailMarshal services in debug mode.
Debug mode enables the user to immediately see the results of the system logging, and is especially useful for resolving problems or when a service fails to start. From a command prompt in the MailMarshal directory enter:
mmengine -debug
(or "mmreceiver -debug" or "mmsender -debug" depending on the service that is to be debugged).
If no entries are written to the event log, the event log may be full, preventing MailMarshal from writing entries to it. A full event log will not in itself cause the services to fail, it will just prevent useful errors being written to the log.
Reply:
Trustwave recommends that the Event Logs is set to at least 4000K in size, and generally they should be configured to overwrite events as needed so that the latest items are always available.
- This article was previously published as:
- NETIQKB29231
- Marshal KB145