MMReceiver service does not start


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

  • MMReceiver service does not start.
  • Event 3004 appears in Application event log.
  • Error: Simple Mail Transport Protocol server is probably already running.
  • Initialization Error: Failed to bind socket to <ip address:25>, an MTA (SMTP)-Simple Mail Transport Protocol server is probably already running (typically the Windows 'Simple Mail Transport Protocol' service) - 10048-WSAEADDRINUSE

Causes:

This issue generally occurs when another SMTP service is running on port 25 (such as the native Microsoft Windows SMTP service). 

Reply:

Two SMTP services cannot listen on the same port (port 25).  To address this issue, choose one of the following actions:

  • Disable the other SMTP service if it is not being used.
  • Move the other service to a different port if that service is required.
  • Move the MailMarshal Receiver Service to a different port if the other service must remain on port 25.

This article was previously published as:
NETIQKB40088

 


Last Modified 5/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10644.aspx