Messages with a large number of recipients are rejected or sent very slowly


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

  • Messages with a large number of recipients are rejected by the server SEG delivers to.
  • Messages with a large number of recipients are sent very slowly.
  • Newsletters take a long time to deliver.
  • Mass mailings take a long time to deliver.
  • The SEG Sender is taking a long time to send messages with a large number of recipients.
  • The SEG Sender is taking a long time to send large messages.
  • Message delivery to a particular domain is slow.

Causes:

The default behavior of the SEG Sender is to send one message regardless of the number of recipients (6.5 and above: up to 250 recipients).

Some other software limits the number of recipients per connection or slows acceptance after a certain number of recipients.

DNS resolution issues or large messages can also delay delivery to domains addressed in the message if the message contains a large number of recipients.

Reply:

You can modify SEG behavior to limit the number of recipients, using Registry entries.

MailMarshal 6.5 and above:

  1. On the Array Manager, edit the Registry (10.X: use Advanced Settings in the Management Console)
  2. Navigate to the SEG Sender key:
    • In version 8.X: HKEY_LOCAL_MACHINE\SOFTWARE\Trustwave\Secure Email Gateway\Default\Sender
    • 10.X: value names have the prefix Sender. (Sender dot).
    • For full details of the location for each product version, see article Q10832.
  3. Add a new DWORD value named MaxRecipients
  4. Set the value (Decimal) to the maximum number of recipients you want batched per connection (Default: 250).
  5. Commit configuration changes. Allow the changes to propagate to all processing servers.
  6. Restart the Sender service on each processing server.

Systems upgraded from MailMarshal 6.4 or below:

If you have previously enabled message splitting with the Registry entry described below, delete the below entry. It can cause issues with temporary files that are not deleted.
  1. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Trustwave\Secure Email Gateway\Default\Engine.
  2. Look for a value SplitMessageWhenTooManyRecipients
  3. If this value is present, delete it.
  4. Commit the configuration changes. 
  5. Restart the Engine service on all processing nodes.

 

Notes:

Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Trustwave cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Make sure that you backup your Registry prior to making any changes.

This article was previously published as:
NETIQKB48126

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10640.aspx