Messages with a large number of recipients are rejected or sent very slowly


This article applies to:

  • Trustwave MailMarshal (SEG)

Symptoms:

  • Messages with a large number of recipients are rejected by the server MailMarshal delivers to.
  • Messages with a large number of recipients are sent very slowly.
  • Newsletters take a long time to deliver.
  • Mass mailings take a long time to deliver.
  • The MailMarshal Sender is taking a long time to send messages with a large number of recipients.
  • The MailMarshal Sender is taking a long time to send large messages.
  • Message delivery to a particular domain is slow.

Causes:

The default behavior of the MailMarshal Sender is to send one message regardless of the number of recipients (up to 250 recipients).

Some other software limits the number of recipients per connection or slows acceptance after a certain number of recipients.

DNS resolution issues or large messages can also delay delivery to domains addressed in the message if the message contains a large number of recipients.

Reply:

You can modify MailMarshal behavior to limit the number of recipients, using Registry entries.

  • In MailMarshal 10.0 and above, open the Management Console and navigate to Advanced Settings. Add a new value:
    • Name: Sender.MaxRecipients
    • Type: Integer
    • Value: The maximum number of recipients you want batched per connection (Default: 250).
  • In MailMarshal 8.X and below, open the Registry Editor on the Array Manager. Within the base registry key, navigate to \Default\Sender
    • In version 8.X: HKEY_LOCAL_MACHINE\SOFTWARE\Trustwave\Secure Email Gateway\Default\Sender
    • For information about the registry location for each version, see article Q10832.
    • Enter the value as a new DWORD value named MaxRecipients and set the value (Decimal) to the maximum number of recipients you want batched per connection (Default: 250).
  • Save your registry settings or configuration settings.
  • Commit the configuration changes and restart the MailMarshal Sender service on each node.
If you have previously enabled message splitting with the Registry entry described below, delete the below entry. It can cause issues with temporary files that are not deleted.
  • For 10.0 and above, look for the value Engine.SplitMessageWhenTooManyRecipients 
  • For 8.X, navigate to in HKEY_LOCAL_MACHINE\SOFTWARE\Trustwave\Secure Email Gateway\Default\Engine.
    • Look for a value SplitMessageWhenTooManyRecipients
  • If this value is present, delete it.
  • Commit the configuration changes. 
  • Restart the Engine service on all processing nodes.

 

Notes:

Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Trustwave cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Make sure that you backup your Registry prior to making any changes.

This article was previously published as:
NETIQKB48126

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10640.aspx