Error: 'TNEF Attribute has invalid checksum' or similar


This article applies to:

  • Trustwave MailMarshal (SEG)
  • Trustwave ECM/MailMarshal Exchange 7.X

Symptoms:

  • Error: 'TNEF Attribute has invalid checksum' or similar
  • Messages deadlettered

Causes:

  • MailMarshal performs checksum tests on any TNEF content it finds in messages. MailMarshal does this to verify integrity of the TNEF component.   

Available Change:

It is possible to disable these checksum tests if you wish to prevent these deadletters from occurring. Trustwave evaluates the level of risk associated with disabling the checksum test as low.

Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Trustwave cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Make sure that you back up your Registry prior to making any changes.

  1. On the Array Manager, edit the Registry (10.X: use Advanced Settings in the Management Console)
  2. Navigate to the SEG Engine key:
    • In version 8.X: HKEY_LOCAL_MACHINE\SOFTWARE\Trustwave\Secure Email Gateway\Default\Engine
    • 10.X: value names have the prefix Engine. (Engine dot).
    • For full details of the location for each product version, see article Q10832.
  3. Add the following value:

    Type = DWORD
    Name = TolerateBadTNEFChecksums
    Data = 1

  4. Commit configuration.

This article was previously published as:
NETIQKB41562

Last Modified 4/1/2020.
https://support.trustwave.com/kb/KnowledgebaseArticle10637.aspx